Updates from January, 2018 Toggle Comment Threads | Keyboard Shortcuts

  • 11:10 am on January 29, 2018 Permalink | Reply
    Tags: bike   

    What? Was the handlebar easier to steal than the seat?



  • 10:42 pm on January 20, 2018 Permalink | Reply

    I think I’ll get a U.S. flag to go out to the streets and waving the flag the day 45* is sent to jail. Should I get a regular sized one or mini handheld ones?

  • 2:52 pm on January 15, 2018 Permalink | Reply  

    So, some forms of machine learning are like a brute force attack on the laws the logic?

    (while rethinking this)

  • 7:31 am on January 14, 2018 Permalink | Reply  

    One unwelcome change in Win10 is how it implements languages and keyboard layouts. In Win7 and before, you could have Windows’s interface language in English but remove English Input Method Editor altogether, and just keep Spanish and Korean. Korean IME has a built-in English entry (using the right alt key), so English was not needed.

    Win10 ties together default keyboard layout with OS display language, so in order to see the OS in English, I must have English IME. So now, instead of having two keyboard layouts, I have three.

    Having two keyboard layouts means that the keyboard switching shortcut (Left Alt+Shift) acts as a on/off switch of sorts. I start typing thinking of typing Spanish and instead Korean comes out, no problemo I hit Alt+Shift without even looking at the taskbar and I will be on my desired IME, If what I see is not what I want, just hitting the shortcut switches the layout, which makes for very easy multilingual multitasking. However, if there’s three keyboard layouts in rotation, the alt+shift shortcut is no longer a on/off switch, it’s a cycle rotator. Now, if what I typed doesn’t come out as I intended, I can’t just mindlessly press the shortcut. if I do that, changes are I will do it a couple of times (like 4 or 5) without realizing that I “missed” the desired IME. So what used to be a “toggle” type shortcut now became a “cycle through” type shortcut. Now I need to look at the taskbar to see which is the current IME, then hit the shortcut, then look at the taskbar again because I don’t remember which IME comes in in the cycle order.

    I wish it was like it was before. I don’t need the English IME.

    • Yongho Kim 김용호 10:16 pm on January 27, 2018 Permalink | Reply

      Today I was able to address it by going into detailed settings for English, then adding Spanish language keyboard layout and removing the English layout (not the English language). This makes it back to a two-IME toggle

  • 9:50 am on January 13, 2018 Permalink | Reply
    Tags: livestreaming   

    Troubleshooting multiple webcams on a USB hub 

    At home, I have been using three webcams for piano livestreaming: one from the top overlooking the piano, another from the side focusing on the right hand, and another for the face. This setup, I thought, has enough visual movement to be less boring to watch. Then there’s a fourth webcam sitting on the monitor, for when I switch attention from the piano to the computer.

    Things were fine when I had all this set up on a corner of the room, piano and computer tightly packed in close quarters. Three webcams (1080p, 720p, 720p) were plugged directly to the computer. The fourth one (1080p) was connected to a USB 2.0 hub.

    Then I decided to unfold this setup throughout the rest of the room, to gain more breathing room. That’s when the problems started.

    Now the piano, around which “audio-type” devices (3 webcams, audio interface, speakers) are clustered, and the computer, are about 10 feet apart. No problem, bring another USB hub into the mix. Then whenever I started up OBS, either all 3 would work (rarely), and more often one of the three webcams would not power up. They were recognized, they were just not sending over a video feed. Which webcam was not sending the feed changed each time I started up OBS. Seems OBS randomly assigns a starting sequence per session.

    • If most of the webcams are plugged to the motherboard, or one webcam per USB  hub, then it’s only up to the computer’s capacity. I tested up to five, it works fine.
    • While two on a USB 2.0 hub:
      • both at 720p seem to be stable
      • both at 1080p will result in one not working
      • 720p and 1080p depends – there is a range of combinations that work or sometimes (sometimes?) doesn’t work. I can’t quite pinpoint the working threshold for this, since just switching around cameras and restarting OBS does not generate reproducible outcomes. Maybe a reboot is required for which combination, which is way too much effort. The audio interface, which is also plugged to the same hub, seems to be a factor in this as well. Other factors could also be whether they were at any point in the current session set up to transmit at 1080p and then later lowered to 720p, webcam maker, etc.
    • Unfortunately, because of the USB 3.0 specifications, a USB 3.0 hub with its much higher bandwidth doesn’t help. USB 3.0 reserves a bandwidth exactly the size of the USB 2.0 spec for 2.0 devices plugged to a 3.0 hub. So all USB2 devices are still competing for the narrow USB2 path while the super wide USB3 bandwidth is very empty. And unlike USB2 webcams, USB3 webcams start at the very hefty $200 per unit rnage.
    • Surprisingly, three on a USB 2.0 hub at times, worked, sometimes, until, I think, I brought an audio interface into the hub. There were other devices on the hub before that, printer and scanner, but those didn’t actively compete for the bandwidth I imagine.

    This is before latency and audio sync between the separate mic and the webcams issue.

  • 7:44 am on January 12, 2018 Permalink | Reply

    You know, maybe from all the meaningless shit 45* spewed to date, maybe the “I’ll take all the heat from this” line is an indication that impeachment is finally imminent. As in, “I’m going down anyways, who cares”

compose new post
next post/next comment
previous post/previous comment
show/hide comments
go to top
go to login
show/hide help
shift + esc